Symptoms
- GPS showing wrong location
- How do I reset vehicle location?
- The driver is adding the address manually to almost all his logs.
- Device not reading location correctly
- Having some localization accuracy issues
- Unit has erroneous location
- Asset keeps getting locked up in the last location
Cause
Poor GPS Quality affects the accuracy of the reported location. You may see these issues manifest themselves as incorrect locations on exception reports, as well as Trips History reports. GPS jamming and invalid GPS messages can also cause these symptoms to surface.
Workaround
- Power cycle to get the device to pick up a fresh GPS signal. Steps can be followed How to reset GO Device
Resolution
- Make sure to do a power cycle and take note of the lights. Red (Power), Green (Cellular), and Blue (GPS).
- Check for GPS faults by going to Maintenance > Diagnostics > Faults.
- Select your Date Period > and click Apply changes.
- The steps from this article can be followed: How do I view engine faults/measurements by vehicle?
- Look for any GPS related faults. You may need to contact Geotab Support for further assistance.
- Confirm device is communicating. If not, perform standard troubleshooting steps.