Symptoms
- User(s) not receiving emailed reports
- Individual recipient is not receiving an emailed report weekly
Cause
Below are several reasons why a user may not be receiving an emailed report:
- The user needs to reset their password - please see MyGeotab: User flagged for password change and not receiving emailed reports
- The user is not in the recipients list
- The user is not in the group which the emailed report is sent to - please see MyGeotab: User with full data access not receiving emailed report
- Report redirection is turned on - please see MyGeotab: Users not getting emailed reports because redirection is turned on
- The data in the report is too big to be sent in an email
- The user does not have the exceptions report clearance
- The user has the setting Receive Emailed Reports turned off in their settings
- There are no vehicles or other users in the group of the person not receiving an email - please see MyGeotab: Users with data access to certain groups not receiving emailed reports
Workaround
If you have not received an emailed report with a set frequency on it, follow the steps below to be able to receive it.
- Click onto Administration > Report Setup > Emailed Reports or Reports > Report Setup > Emailed Reports
- Click on the missing report (Make sure to click right ABOVE Preview)
- Go on the third tab --> EmailReports
- Choose and add the recipient(s) on the display options
- Set up the report so the date range matches the one that was missed on the report data configuration
- Inthe field, next run set it up so you may receive the email as soon as possible
- Click Save
- Make sure that you have received in your inboxthe desired report
- Put back the report data configuration field to what they were so the correct report will be emailed to you in the future
- Click Save
Resolution
To ensure that future runs of the reports will be emailed to the correct recipient(s), you have to select the right options in the four fields in the display options.
- Click onto Administration > Report Setup > Emailed Reports or Reports > Report Setup > Emailed Reports
- Click on the missing report (Make sure to click right above " Preview ")
- Go on the third tab --> Emailed Reports
- Choose and add the recipient(s) on the display options
- Click Save
Additional Information
You can verify if a report has not been sent by going to Administration>System>Audit log. Click the Options box and in the audit type section, put in "Report not sent"