Symptoms
- Vehicles are not showing on Map
- Just installed my device, and I m on the database but, cant see the vehicle on the maps. Whats going on with it?
- I cant see any vehicles on my account.
- Why all vehicles are not visible when I click Map on the database?
- Why am I not seeing vehicles on the map?
- I Can't See My Driver on the Map.
- I cannot see my trucks location.
Cause
- No vehicles were selected to view on the map.
- Vehicle was not selected.
- User logged into an incorrect database.
- No vehicle in the account
Resolution
- In MyGeotab, select Map
- Click on the drop-down arrow located between the search field and Map options drop-down .
- Click Select All
- If there is no Select all option, click Remove all and then click Select all
Additional Information
- This article is part of the following resolution paths: MyGeotab: can't see vehicles on the map
- Related article: