Skip to content

GO Device: No GPS Data or invalid trips due to too many invalid GPS points

Updated 

Symptoms

  • Incorrect Trips history
  • Device not recording GPS data
  • Fault: "Telematics device fault: GPS quality poor (bad device install or vehicle undercover)"
  • FAULT_INVALID_GPS_MSGS
  • Vehicle is not reporting trip history
  • System is not updating on website map

Cause

Either due to bad installation or because the GPS module is broken, the device is failing to validate any new GPS coordinates that are being read. It defaults to the last valid GPS point until a new valid GPS point is registered.

Resolution

  1. Check the installation of the vehicle to ensure that the device is secure
  2. Follow the steps mentioned in the troubleshooting steps
  3. Ensure that device is plugged in securely and power cycled
  4. Move the device to another location with better access to the sky for properGPS reception (i.e., not covered or under the hood,on the dashboard as close as possible to the windshield)
  5. As the last resort, use the following custom parameter to reset the GPS validation protocol. Remove the custom parameter after GPS has been reset

<GoParameters><Parameter Description="Reset GPS If Too Many Invalid" Offset="11" Bytes="40"/></GoParameters>


Additional Information

Contact Geotab Support if the above steps do not work.