People: How can I reset my password
Symptoms
  • Unable to log in to MyGeotab.
  • Unable to log in to the Geotab Drive app.
  • Error: Invalid username or password.
  • Password is unknown or incorrect.
  • Password reset email has not been received by the end-user.
  • I can't remember my drive app password.
  • I'm a new driver and I'm trying to drive butI can't log in (Unknown username).
  • I dont remember my password and my username.
  • Can't access the database and the reset link doesn't work
  • Last week my computer broke and get a new one but now I don't remember the username and password for one database so can you provide me with that, please.
  • I forgot my password.
  • Driver cannot login due to forgetting username and password
  • I can't get a new password in order to log into my account
  • I have been off for some weeks and come back today and my password is not working/I forgot my password.
Steps to Reproduce
Cause

Password is unknown or incorrect.

Workaround
Resolution

The password for your user account should be reset. Follow the steps below based on the type of username you have:

If your username is an email address:

        Follow the steps here to reset your own password:

How to reset password in MyGeotab with an email address (Forgot Password) OR

        An administrator can send the password reset email by following the steps here:

How can administrators force password resets for other users?

If your username is not an email address:

        Reach out to an administrator to manually reset the password. See here:

MyGeotab: How can an Administrator change a user's password in MyGeotab?

First Affected Version
Fixed Version
Additional Information
  • How to reset my password
  • How to reset a password for a user
Reason for Archiving